New here

silver13ltzrs

New member
Last month I picked up a 2013 LTZ RS.

I really like the car and the mileage so far. No issues other than the radio cutting out, but I think I found a solution for this.

I don't plan on modding it performance wise... but added tint and plastidipped the bowties.

After tint... (5% rears, 20% sides, 35% windshield)

IMG_5831_zps72e4bb0f.jpg


IMG_5834_zps779d1fb1.jpg


IMG_5838_zpscbf0d09e.jpg


IMG_5828_zps4f08abc5.jpg
 

06mistreSS

New member
Welcome to the Forum. If you don't mind me asking, where about in Michigan are you located? I'm in the Ann Arbor area.

Very nice looking car, I like the silver with the window tint. I'm looking at going with 18% tint in the spring myself. Sounds like you also had a similar electrical issue that I had experienced. I just got mine resolved. I've had my 2011 for a year now and my issue seemed to be related to temperature; seemed to be a problem mostly in cooler temps.
 

silver13ltzrs

New member
Thanks for the replies!

Welcome to the Forum. If you don't mind me asking, where about in Michigan are you located? I'm in the Ann Arbor area.

Very nice looking car, I like the silver with the window tint. I'm looking at going with 18% tint in the spring myself. Sounds like you also had a similar electrical issue that I had experienced. I just got mine resolved. I've had my 2011 for a year now and my issue seemed to be related to temperature; seemed to be a problem mostly in cooler temps.


Thanks!

I'm in Westland, not too far from you.
 

silver13ltzrs

New member
Ah yep, not too far at all. Cool.

Did you debadge the RS badges from the front side doors?

Yes, then I thought it looked like something was missing.

I misplaced one, so I looked on eBay and didn't see any. I ended up buying some larger ones, but am not sure how I feel about them. I don't mind the size, and I like that they are more "3D" looking, but the font is different.

image_zpsd92f3854.jpg
 

Members online

Top